CVE-2007-1536

NameCVE-2007-1536
DescriptionInteger underflow in the file_printf function in the "file" program before 4.20 allows user-assisted attackers to execute arbitrary code via a file that triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1274-1
NVD severityhigh (attack range: remote)
Debian Bugs415362

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)wheezy5.11-2+deb7u8fixed
wheezy (security)5.11-2+deb7u9fixed
jessie1:5.22+15-2+deb8u3fixed
stretch (security), stretch1:5.30-1+deb9u1fixed
buster, sid1:5.32-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)4.20-1high415362
filesourceetch4.17-5etch1highDSA-1274-1
filesourcesarge4.12-1sarge1highDSA-1274-1

Notes

Has got lots of reverse dependencies.
Some of them process remotely supplied untrusted input.

Search for package or bug name: Reporting problems