CVE-2007-1595

NameCVE-2007-1595
DescriptionThe Asterisk Extension Language (AEL) in pbx/pbx_ael.c in Asterisk does not properly generate extensions, which allows remote attackers to execute arbitrary extensions and have an unknown impact by specifying an invalid extension in a certain form.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2fixed
buster (security)1:16.28.0~dfsg-0+deb10u1fixed
bullseye1:16.16.1~dfsg-1+deb11u1fixed
bullseye (security)1:16.28.0~dfsg-0+deb11u1fixed
bookworm, sid1:20.0.0~dfsg+~cs6.12.40431414-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcesarge(not affected)
asterisksourceetch(not affected)
asterisksource(unstable)1:1.4.0~dfsg-1low

Notes

[etch] - asterisk <not-affected> (Only affects 1.4.x)
[sarge] - asterisk <not-affected> (Only affects 1.4.x)

Search for package or bug name: Reporting problems