CVE-2007-1614

NameCVE-2007-1614
DescriptionStack-based buffer overflow in the zzip_open_shared_io function in zzip/file.c in ZZIPlib Library before 0.13.49 allows user-assisted remote attackers to cause a denial of service (application crash) or execute arbitrary code via a long filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-56-1
NVD severityhigh
Debian Bugs436701

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zziplib (PTS)stretch0.13.62-3.2~deb9u1fixed
buster0.13.62-3.2fixed
bullseye0.13.62-3.3fixed
bookworm, sid0.13.72+dfsg.1-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zziplibsourcelenny0.12.83-8lenny1DTSA-56-1
zziplibsource(unstable)0.13.49-0low436701

Notes

[etch] - zziplib <no-dsa> (Minor issue)
http://www.securitylab.ru/forum/read.php?FID=21&TID=40858&MID=326187#message326187
If an attacker can supply arbitrary file names, we likely suffer from
an information disclosure issue anyway.

Search for package or bug name: Reporting problems