CVE-2007-1711

NameCVE-2007-1711
DescriptionDouble free vulnerability in the unserializer in PHP 4.4.5 and 4.4.6 allows context-dependent attackers to execute arbitrary code by overwriting variables pointing to (1) the GLOBALS array or (2) the session data in _SESSION. NOTE: this issue was introduced when attempting to patch CVE-2007-1701 (MOPB-31-2007).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1282-1, DSA-1283-1
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4sourcesarge4:4.3.10-20DSA-1282-1
php4sourceetch6:4.4.4-8+etch2DSA-1282-1
php4source(unstable)6:4.4.6-2
php5sourceetch5.2.0-8+etch3DSA-1283-1
php5source(unstable)5.2.0-9

Notes

register_globals not supported

Search for package or bug name: Reporting problems