CVE-2007-1777

NameCVE-2007-1777
DescriptionInteger overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to execute arbitrary code via a ZIP archive that contains an entry with a length value of 0xffffffff, which is incremented before use in an emalloc call, triggering a heap overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1282-1, DSA-1283-1, DTSA-39-1, DTSA-40-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)6:4.4.6-1medium
php4sourceetch6:4.4.4-8+etch2highDSA-1282-1
php4sourcelenny6:4.4.4-9+lenny1highDTSA-40-1
php4sourcesarge4:4.3.10-20highDSA-1282-1
php5source(unstable)5.2.0-11medium
php5sourceetch5.2.0-8+etch3highDSA-1283-1
php5sourcelenny5.2.0-10+lenny1highDTSA-39-1

Search for package or bug name: Reporting problems