CVE-2007-1860

NameCVE-2007-1860
Descriptionmod_jk in Apache Tomcat JK Web Server Connector 1.2.x before 1.2.23 decodes request URLs within the Apache HTTP Server before passing the URL to Tomcat, which allows remote attackers to access protected pages via a crafted prefix JkMount, possibly involving double-encoded .. (dot dot) sequences and directory traversal, a related issue to CVE-2007-0450.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1312-1
NVD severitymedium (attack range: remote)
Debian Bugs425836

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache-mod-jk (PTS)wheezy, wheezy (security)1:1.2.37-1+deb7u1fixed
jessie (security), jessie1:1.2.37-4+deb8u1fixed
buster, sid, stretch1:1.2.42-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache-mod-jksource(unstable)1:1.2.23-1medium425836
libapache-mod-jksourceetch1:1.2.18-3etch1mediumDSA-1312-1
libapache-mod-jksourcesarge1:1.2.5-2sarge1mediumDSA-1312-1

Search for package or bug name: Reporting problems