CVE-2007-1870

NameCVE-2007-1870
Descriptionlighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1303-1
NVD severityhigh (attack range: remote)
Debian Bugs422254

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lighttpd (PTS)wheezy1.4.31-4+deb7u4fixed
wheezy (security)1.4.31-4+deb7u5fixed
jessie (security), jessie1.4.35-4+deb8u1fixed
buster, sid, stretch1.4.45-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lighttpdsource(unstable)1.4.15-1low422254
lighttpdsourceetch1.4.13-4etch1highDSA-1303-1

Search for package or bug name: Reporting problems