CVE-2007-1887

NameCVE-2007-1887
DescriptionBuffer overflow in the sqlite_decode_binary function in the bundled sqlite library in PHP 4 before 4.4.5 and PHP 5 before 5.2.1 allows context-dependent attackers to execute arbitrary code via an empty value of the in parameter, as demonstrated by calling the sqlite_udf_decode_binary function with a 0x01 character.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1283-1, DTSA-39-1
NVD severityhigh (attack range: remote)
Debian Bugs420456

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)(not affected)
php4-sqlitesource(unstable)(unfixed)medium420456
php5source(unstable)5.2.0-11medium
php5sourceetch5.2.0-8+etch3highDSA-1283-1
php5sourcelenny5.2.0-10+lenny1highDTSA-39-1

Notes

- php4 <not-affected> (SQLite not enabled in PHP 4 packages)
php5 is vulnerable due to improper use of the system sqlite libs

Search for package or bug name: Reporting problems