|Description||bgpd/bgp_attr.c in Quagga 0.98.6 and earlier, and 0.99.6 and earlier 0.99 versions, does not validate length values in the MP_REACH_NLRI and MP_UNREACH_NLRI attributes, which allows remote attackers to cause a denial of service (daemon crash or exit) via crafted UPDATE messages that trigger an assertion error or out of bounds read.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)|
|NVD severity||medium (attack range: remote)|
Vulnerable and fixed packages
The table below lists information on source packages.
|quagga (PTS)||jessie (security), jessie||0.99.23.1-1+deb8u5||fixed|
|stretch (security), stretch||1.1.1-3+deb9u2||fixed|
The information below is based on the following data on fixed versions.
The attributes are non-transitive, which means that they
are not propagated via BGP and therefore must originate
from a peer (which is explicitly configured).