CVE-2007-1995

NameCVE-2007-1995
Descriptionbgpd/bgp_attr.c in Quagga 0.98.6 and earlier, and 0.99.6 and earlier 0.99 versions, does not validate length values in the MP_REACH_NLRI and MP_UNREACH_NLRI attributes, which allows remote attackers to cause a denial of service (daemon crash or exit) via crafted UPDATE messages that trigger an assertion error or out of bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1293-1
NVD severitymedium (attack range: remote)
Debian Bugs418323

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)wheezy0.99.22.4-1+wheezy2fixed
wheezy (security)0.99.22.4-1+wheezy3+deb7u1fixed
jessie (security), jessie0.99.23.1-1+deb8u3fixed
buster, stretch, sid1.1.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.6-5low418323
quaggasourceetch0.99.5-5etch2mediumDSA-1293-1
quaggasourcesarge0.98.3-7.4mediumDSA-1293-1

Notes

The attributes are non-transitive, which means that they
are not propagated via BGP and therefore must originate
from a peer (which is explicitly configured).

Search for package or bug name: Reporting problems