CVE-2007-2348

NameCVE-2007-2348
Descriptionmirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lftp (PTS)wheezy4.3.6-1+deb7u2vulnerable
jessie4.6.0-1+deb8u1vulnerable
stretch4.7.4-1vulnerable
buster, sid4.8.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lftpsource(unstable)(unfixed)unimportant

Notes

Non-issue, also already documented as potentially risky

Search for package or bug name: Reporting problems