CVE-2007-2459

NameCVE-2007-2459
DescriptionHeap-based buffer overflow in the BMP reader (bmp.c) in Imager perl module (libimager-perl) 0.45 through 0.56 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted 8-bit/pixel compressed BMP files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1498-1
NVD severityhigh (attack range: remote)
Debian Bugs421582

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libimager-perl (PTS)wheezy0.91+dfsg-2fixed
jessie1.000+dfsg-2fixed
buster, sid, stretch1.005+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libimager-perlsource(unstable)0.58-1high421582
libimager-perlsourceetch0.50-1etch1highDSA-1498-1

Search for package or bug name: Reporting problems