CVE-2007-2509

NameCVE-2007-2509
DescriptionCRLF injection vulnerability in the ftp_putcmd function in PHP before 4.4.7, and 5.x before 5.2.2 allows remote attackers to inject arbitrary FTP commands via CRLF sequences in the parameters to earlier FTP commands.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1295-1, DSA-1296-1, DTSA-39-1, DTSA-40-1
NVD severitylow (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.36-0+deb7u3fixed
jessie5.6.5+dfsg-2fixed
sid5.6.6+dfsg-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)4.4.7-1low
php4sourceetch6:4.4.4-8+etch3lowDSA-1296-1
php4sourcelenny6:4.4.4-9+lenny1lowDTSA-40-1
php4sourcesarge4:4.3.10-21lowDSA-1296-1
php5source(unstable)5.2.2-1low
php5sourceetch5.2.0-8+etch4lowDSA-1295-1
php5sourcelenny5.2.0-10+lenny1lowDTSA-39-1

Search for package or bug name: Reporting problems