CVE-2007-2721

NameCVE-2007-2721
DescriptionThe jpc_qcx_getcompparms function in jpc/jpc_cs.c for the JasPer JPEG-2000 library (libjasper) before 1.900 allows remote user-assisted attackers to cause a denial of service (crash) and possibly corrupt the heap via malformed image files, as originally demonstrated using imagemagick convert.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2036-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs413033, 447188, 528543, 561717
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)squeeze, squeeze (security)8.71~dfsg2-9+squeeze1fixed
wheezy9.05~dfsg-6.3+deb7u1fixed
stretch, sid, jessie9.06~dfsg-2fixed
jasper (PTS)squeeze, squeeze (security)1.900.1-7+squeeze1fixed
squeeze (lts)1.900.1-7+squeeze4fixed
wheezy1.900.1-13+deb7u2fixed
wheezy (security)1.900.1-13+deb7u3fixed
stretch, sid, jessie1.900.1-debian1-2.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)8.61.dfsg.1~svn8187-1.1medium447188
gs-gplsource(unstable)(unfixed)medium561717
jaspersource(unstable)1.900.1-6medium413033, 528543
jaspersourcelenny1.900.1-5.1+lenny1mediumDSA-2036-1

Notes

Jasper was initially fixed in 1.900.1-3, but the fix got dropped later, see #528543
see http://ghostscript.com/pipermail/gs-cvs/2007-October/007877.html

Search for package or bug name: Reporting problems