CVE-2007-2807

NameCVE-2007-2807
DescriptionStack-based buffer overflow in mod/server.mod/servrmsg.c in Eggdrop 1.6.18, and possibly earlier, allows user-assisted, remote IRC servers to execute arbitrary code via a long private message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1448-1, DSA-1826-1
NVD severitymedium (attack range: remote)
Debian Bugs427157

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eggdrop (PTS)wheezy1.6.20-1fixed
buster, sid, jessie, stretch1.6.21-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eggdropsource(unstable)1.6.18-1.1medium427157
eggdropsourceetch1.6.18-1etch2mediumDSA-1826-1
eggdropsourcelenny1.6.19-1.1+lenny1mediumDSA-1826-1
eggdropsourcesarge1.6.17-3sarge1mediumDSA-1448-1

Search for package or bug name: Reporting problems