CVE-2007-2837

NameCVE-2007-2837
DescriptionThe (1) getRule and (2) getChains functions in server/rules.cpp in fireflierd (fireflier-server) in FireFlier 1.1.6 allow local users to overwrite arbitrary files via a symlink attack on the /tmp/fireflier.rules temporary file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1326-1
NVD severitylow

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefliersourcesarge1.1.5-1sarge1DSA-1326-1
firefliersourceetch1.1.6-3etch1DSA-1326-1
firefliersource(unstable)1.1.7

Search for package or bug name: Reporting problems