CVE-2007-2865

NameCVE-2007-2865
DescriptionCross-site scripting (XSS) vulnerability in sqledit.php in phpPgAdmin 4.1.1 allows remote attackers to inject arbitrary web script or HTML via the server parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1693-1
NVD severityhigh (attack range: remote)
Debian Bugs427151

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phppgadmin (PTS)wheezy5.0.4-1fixed
jessie5.1-1.1fixed
buster, sid, stretch5.1+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phppgadminsource(unstable)4.1.2-1low427151
phppgadminsourceetch4.0.1-3.1etch1highDSA-1693-1
phppgadminsourcesarge(not affected)

Notes

[sarge] - phppgadmin <not-affected> (Vulnerable code not present)
http://phppgadmin.cvs.sourceforge.net/phppgadmin/webdb/classes/Misc.php?r1=1.156&r2=1.157&pathrev=MAIN

Search for package or bug name: Reporting problems