CVE-2007-3023

NameCVE-2007-3023
Descriptionunsp.c in ClamAV before 0.90.3 and 0.91 before 0.91rc1 does not properly calculate the end of a certain buffer, with unknown impact and remote attack vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1320-1, DTSA-43-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)squeeze0.98.1+dfsg-1+deb6u3fixed
squeeze (lts)0.98.7+dfsg-0+deb6u2fixed
wheezy0.98.5+dfsg-0+deb7u2fixed
jessie0.98.7+dfsg-0+deb8u1fixed
stretch0.98.7+dfsg-2fixed
sid0.98.7+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.90.3-1high
clamavsourceetch0.90.1-3etch3highDSA-1320-1
clamavsourcelenny0.90.1-3.1lenny3highDTSA-43-1
clamavsourcesarge0.84-2.sarge.17highDSA-1320-1

Search for package or bug name: Reporting problems