CVE-2007-3115

NameCVE-2007-3115
DescriptionMultiple memory leaks in server/MaraDNS.c in MaraDNS before 1.2.12.06, and 1.3.x before 1.3.05, allow remote attackers to cause a denial of service (memory consumption) via (1) reverse lookups or (2) requests for records in a class other than Internet (IN), a different set of affected versions than CVE-2007-3114 and CVE-2007-3116.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1319-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
maradns (PTS)squeeze1.4.03-1.1+squeeze1fixed
wheezy1.4.12-5fixed
sid2.0.09-3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
maradnssource(unstable)1.2.12.06-1high
maradnssourceetch1.2.12.04-1etch1highDSA-1319-1
maradnssourcesarge(not affected)

Notes

[sarge] - maradns <not-affected> (1.0.x branch not affected)

Search for package or bug name: Reporting problems