DescriptionGimp before 2.8.22 allows context-dependent attackers to cause a denial of service (crash) via an ICO file with an InfoHeader containing a Height of zero, a similar issue to CVE-2007-2237.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs885382

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gimp (PTS)wheezy2.8.2-2+deb7u1vulnerable
wheezy (security)2.8.2-2+deb7u3vulnerable
jessie (security)2.8.14-1+deb8u2vulnerable
stretch (security), stretch2.8.18-1+deb9u1vulnerable
buster, sid2.8.20-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

Notes (master) (gimp-2-8)

Search for package or bug name: Reporting problems