CVE-2007-3409

NameCVE-2007-3409
DescriptionNet::DNS before 0.60, a Perl module, allows remote attackers to cause a denial of service (stack consumption) via a malformed compressed DNS packet with self-referencing pointers, which triggers an infinite loop.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1515-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libnet-dns-perl (PTS)wheezy0.66-2fixed
jessie (security), jessie0.81-2+deb8u1fixed
stretch1.07-1fixed
buster, sid1.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libnet-dns-perlsource(unstable)0.60-1low
libnet-dns-perlsourceetch0.59-1etch1mediumDSA-1515-1
libnet-dns-perlsourcesarge0.48-1sarge1mediumDSA-1515-1

Search for package or bug name: Reporting problems