CVE-2007-3564

NameCVE-2007-3564
Descriptionlibcurl 7.14.0 through 7.16.3, when built with GnuTLS support, does not check SSL/TLS certificate expiration or activation dates, which allows remote attackers to bypass certain access restrictions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1333-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)squeeze, squeeze (security)7.21.0-2.1+squeeze8fixed
squeeze (lts)7.21.0-2.1+squeeze12fixed
wheezy7.26.0-1+wheezy11fixed
wheezy (security)7.26.0-1+wheezy13fixed
jessie7.38.0-4fixed
jessie (security)7.38.0-4+deb8u2fixed
stretch, sid7.42.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.16.4-1low
curlsourceetch7.15.5-1etch1highDSA-1333-1

Search for package or bug name: Reporting problems