CVE-2007-3912

NameCVE-2007-3912
Descriptioncheckrestart in debian-goodies before 0.34 allows local users to gain privileges via shell metacharacters in the name of the executable file for a running process.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1527-1
NVD severityhigh (attack range: local)
Debian Bugs440411
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
debian-goodies (PTS)squeeze0.53fixed
wheezy0.61fixed
jessie0.63fixed
stretch, sid0.64fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
debian-goodiessource(unstable)0.34medium440411
debian-goodiessourceetch0.27+etch1highDSA-1527-1
debian-goodiessourcesarge0.23+sarge1highDSA-1527-1

Search for package or bug name: Reporting problems