CVE-2007-3998

NameCVE-2007-3998
DescriptionThe wordwrap function in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, does not properly use the breakcharlen variable, which allows remote attackers to cause a denial of service (divide-by-zero error and application crash, or infinite loop) via certain arguments, as demonstrated by a 'chr(0), 0, ""' argument set.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1444-1, DSA-1578-1, DTSA-61-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.41-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.9+dfsg-0+deb8u1fixed
stretch, sid5.6.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)(unfixed)low
php4sourceetch6:4.4.4-8+etch6mediumDSA-1578-1
php5source(unstable)5.2.4-1low
php5sourceetch5.2.0-8+etch9mediumDSA-1444-1
php5sourcelenny5.2.3-1+lenny1mediumDTSA-61-1

Notes

this applies to php4 as well
i think it is medium since it can be easily used to DoS on shared hosting systems
a diff between 5.2.3 (debian) and 5.2.4 (upstream) of ext/standard/string.c
so maybe this is already fixed in 5.2.3, not sure
fixed in php5/etch svn
http://cvs.php.net/viewcvs.cgi/php-src/ext/standard/string.c?r1=1.445.2.14.2.63&r2=1.445.2.14.2.64

Search for package or bug name: Reporting problems