CVE-2007-3999

NameCVE-2007-3999
DescriptionStack-based buffer overflow in the svcauth_gss_validate function in lib/rpc/svc_auth_gss.c in the RPCSEC_GSS RPC library (librpcsecgss) in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and some third-party applications that use krb5, allows remote attackers to cause a denial of service (daemon crash) and probably execute arbitrary code via a long string in an RPC message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1367-1, DSA-1368-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)squeeze (security), squeeze1.8.3+dfsg-4squeeze7fixed
squeeze (lts)1.8.3+dfsg-4squeeze9fixed
wheezy1.10.1+dfsg-5+deb7u2fixed
wheezy (security)1.10.1+dfsg-5+deb7u3fixed
jessie, sid1.12.1+dfsg-18fixed
librpcsecgss (PTS)squeeze0.19-2fixed
wheezy0.19-5fixed
jessie, sid0.19-7fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.6.dfsg.1-7high
krb5sourceetch1.4.4-7etch4highDSA-1367-1
krb5sourcesarge(not affected)
librpcsecgsssource(unstable)0.14-3high
librpcsecgsssourceetch0.14-2etch1highDSA-1368-1

Notes

[sarge] - krb5 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems