CVE-2007-4048

NameCVE-2007-4048
DescriptionCross-site scripting (XSS) vulnerability in index.php in phpSysInfo 2.5.4-dev and earlier allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-58-1
NVD severitymedium (attack range: remote)
Debian Bugs435935, 435936, 435937, 472685

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpsysinfo (PTS)jessie3.0.17-1fixed
sid3.2.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
egroupwaresource(unstable)1.2.107-2.dfsg-1.1low435937
phpgroupwaresource(unstable)0.9.16.012-1low435936, 472685
phpgroupwaresourceetch(not affected)
phpgroupwaresourcelenny0.9.16.011-3lenny2mediumDTSA-58-1
phpsysinfosource(unstable)2.5.1-6.1unimportant435935

Notes

[etch] - phpgroupware <not-affected> (Affected code is not used in phpgroupware)
phpsysinfo alone doesn't maintain any data, which makes this an issue

Search for package or bug name: Reporting problems