CVE-2007-4476

NameCVE-2007-4476
DescriptionBuffer overflow in the safer_name_suffix function in GNU tar has unspecified attack vectors and impact, resulting in a "crashing stack."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1438-1, DSA-1566-1
NVD severityhigh (attack range: remote)
Debian Bugs441444, 449222
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cpio (PTS)squeeze2.11-4fixed
squeeze (lts)2.11-4+deb6u1fixed
wheezy, wheezy (security)2.11+dfsg-0.1+deb7u1fixed
stretch, jessie, sid2.11+dfsg-4.1fixed
tar (PTS)squeeze1.23-3fixed
wheezy1.26+dfsg-0.1fixed
stretch, jessie, sid1.27.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cpiosource(unstable)2.9-5low449222
cpiosourceetch2.6-18.1+etch1highDSA-1566-1
tarsource(unstable)1.18-1low441444
tarsourceetch1.16-2etch1highDSA-1438-1
tarsourcesarge1.14-2.4highDSA-1438-1

Search for package or bug name: Reporting problems