CVE-2007-4542

NameCVE-2007-4542
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1539-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs439346
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)squeeze5.6.5-2+squeeze3fixed
squeeze (security)5.6.5-2+squeeze2fixed
wheezy6.0.1-3.2+deb7u2fixed
jessie, sid6.4.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)4.10.3-1medium439346
mapserversourceetch4.10.0-5.1+etch2mediumDSA-1539-1

Search for package or bug name: Reporting problems