CVE-2007-4601

NameCVE-2007-4601
DescriptionA regression error in tcp-wrappers 7.6.dbs-10 and 7.6.dbs-11 might allow remote attackers to bypass intended access restrictions when a service uses libwrap but does not specify server connection information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs405342

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcp-wrappers (PTS)jessie7.6.q-25fixed
stretch7.6.q-26fixed
buster, sid7.6.q-28fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcp-wrapperssource(unstable)7.6.dbs-12medium405342
tcp-wrapperssourceetch(not affected)
tcp-wrapperssourcesarge(not affected)

Notes

[etch] - tcp-wrappers <not-affected> (Vulnerability was introduced in -10)
[sarge] - tcp-wrappers <not-affected> (Vulnerability was introduced in -10)

Search for package or bug name: Reporting problems