CVE-2007-4619

NameCVE-2007-4619
DescriptionMultiple integer overflows in Free Lossless Audio Codec (FLAC) libFLAC before 1.2.1, as used in Winamp before 5.5 and other products, allow user-assisted remote attackers to execute arbitrary code via a malformed FLAC file that triggers improper memory allocation, resulting in a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1469-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flac (PTS)wheezy, wheezy (security)1.2.1-6+deb7u1fixed
jessie1.3.0-3fixed
buster, stretch, sid1.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flacsource(unstable)1.2.1-1medium
flacsourceetch1.1.2-8highDSA-1469-1
flacsourcesarge1.1.1-5sarge1highDSA-1469-1

Search for package or bug name: Reporting problems