CVE-2007-4743

NameCVE-2007-4743
DescriptionThe original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1367-1, DSA-1387-1
NVD severityhigh
Debian Bugs441209, 441393

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)stretch1.15-1+deb9u1fixed
stretch (security)1.15-1+deb9u2fixed
buster1.17-3+deb10u1fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6fixed
bookworm, sid1.18.3-7fixed
librpcsecgss (PTS)buster, stretch0.19-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcesarge(not affected)
krb5sourceetch1.4.4-7etch4DSA-1367-1
krb5source(unstable)1.6.dfsg.1-7high441209
librpcsecgsssourceetch0.14-2etch3DSA-1387-1
librpcsecgsssource(unstable)0.14-4high441393

Notes

[sarge] - krb5 <not-affected> (Vulnerable code not present)
http://article.gmane.org/gmane.comp.encryption.kerberos.announce/86
1.6.dfsg.1-7 somehow already includes the updated version

Search for package or bug name: Reporting problems