CVE-2007-4829

NameCVE-2007-4829
DescriptionDirectory traversal vulnerability in the Archive::Tar Perl module 1.36 and earlier allows user-assisted remote attackers to overwrite arbitrary files via a TAR archive that contains a file whose name is an absolute path or has ".." sequences.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs449544

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)stretch5.24.1-3+deb9u7fixed
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-6+deb10u1fixed
bullseye5.32.1-2fixed
sid5.32.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchive-tar-perlsource(unstable)1.38-1low449544
perlsourceetch(not affected)
perlsource(unstable)5.10.0-19

Notes

[etch] - perl <not-affected> (Was merged into Perl as of 5.10)
[sarge] - libarchive-tar-perl <no-dsa> (Minor issue)
[etch] - libarchive-tar-perl <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems