CVE-2007-4965

NameCVE-2007-4965
DescriptionMultiple integer overflows in the imageop module in Python 2.5.1 and earlier allow context-dependent attackers to cause a denial of service (application crash) and possibly obtain sensitive information (memory contents) via crafted arguments to (1) the tovideo method, and unspecified other vectors related to (2) imageop.c, (3) rbgimgmodule.c, and other files, which trigger heap-based buffer overflows.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1551-1, DSA-1620-1
NVD severitymedium (attack range: remote)
Debian Bugs443333, 443335
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.5 (PTS)squeeze2.5.5-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.4source(unstable)2.4.4-7low443335
python2.4sourceetch2.4.4-3+etch1mediumDSA-1551-1
python2.5source(unstable)2.5.1-6low443333
python2.5sourceetch2.5-5+etch1mediumDSA-1620-1

Notes

[etch] - python2.5 <no-dsa> (Minor issue)
[sarge] - python2.5 <no-dsa> (Minor issue)
[etch] - python2.4 <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems