CVE-2007-4986

NameCVE-2007-4986
DescriptionMultiple integer overflows in ImageMagick before 6.3.5-9 allow context-dependent attackers to execute arbitrary code via a crafted (1) .dcm, (2) .dib, (3) .xbm, (4) .xcf, or (5) .xwd image file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1858-1, DSA-1903-1, DTSA-63-1
NVD severitymedium (attack range: remote)
Debian Bugs444266, 444267

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1fixed
wheezy (security)1.3.16-1.1+deb7u11fixed
jessie1.3.20-3+deb8u1fixed
jessie (security)1.3.20-3+deb8u2fixed
stretch1.3.25-8fixed
buster, sid1.3.26-15fixed
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4fixed
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie8:6.8.9.9-5+deb8u9fixed
jessie (security)8:6.8.9.9-5+deb8u10fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u1fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.1.11-1medium444266
graphicsmagicksourceetch1.1.7-13+etch1mediumDSA-1903-1
graphicsmagicksourcelenny1.1.11-3.2+lenny1mediumDSA-1903-1
imagemagicksource(unstable)7:6.2.4.5.dfsg1-2medium444267
imagemagicksourceetch7:6.2.4.5.dfsg1-0.15+etch1mediumDSA-1858-1
imagemagicksourcelenny7:6.3.7.9.dfsg2-1~lenny3mediumDSA-1858-1

Search for package or bug name: Reporting problems