CVE-2007-4995

NameCVE-2007-4995
DescriptionOff-by-one error in the DTLS implementation in OpenSSL 0.9.8 before 0.9.8f allows remote attackers to execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1571-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)wheezy1.0.1e-2+deb7u20fixed
wheezy (security)1.0.1t-1+deb7u2fixed
jessie (security), jessie1.0.1t-1+deb8u6fixed
stretch1.1.0f-3fixed
buster, sid1.1.0f-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)0.9.8f-1low
opensslsourceetch0.9.8c-4etch3highDSA-1571-1
opensslsourcesarge(not affected)
openssl096source(unstable)(not affected)
openssl097source(unstable)(not affected)

Notes

- openssl097 <not-affected> (DTLS support was introduced in 0.9.8)
- openssl096 <not-affected> (DTLS support was introduced in 0.9.8)
[sarge] - openssl <not-affected> (DTLS support was introduced in 0.9.8)

Search for package or bug name: Reporting problems