CVE-2007-5116

NameCVE-2007-5116
DescriptionBuffer overflow in the polymorphic opcode support in the Regular Expression Engine (regcomp.c) in Perl 5.8 allows context-dependent attackers to execute arbitrary code by switching from byte to Unicode (UTF) characters in a regular expression.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1400-1, DTSA-78-1
NVD severityhigh (attack range: remote)
Debian Bugs450794
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)squeeze (security), squeeze5.10.1-17squeeze6fixed
wheezy5.14.2-21+deb7u2fixed
sid, jessie5.20.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.8.8-12medium450794
perlsourceetch5.8.8-7etch1highDSA-1400-1
perlsourcelenny5.8.8-11.1+lenny1highDTSA-78-1
perlsourcesarge5.8.4-8sarge6highDSA-1400-1

Notes

http://public.activestate.com/cgi-bin/perlbrowse/30647

Search for package or bug name: Reporting problems