CVE-2007-5137

NameCVE-2007-5137
DescriptionBuffer overflow in the ReadImage function in generic/tkImgGIF.c in Tcl (Tcl/Tk) 8.4.13 through 8.4.15 allows remote attackers to execute arbitrary code via multi-frame interlaced GIF files in which later frames are smaller than the first. NOTE: this issue is due to an incorrect patch for CVE-2007-5378.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1743-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libtk-img (PTS)squeeze1:1.3-release-9fixed
wheezy1:1.3-release-12fixed
sid, jessie1:1.4.2+dfsg-2fixed
tk8.4 (PTS)squeeze8.4.19-4fixed
wheezy8.4.19-5fixed
sid8.4.20-7fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libtk-imgsource(unstable)1.3-release-8medium
libtk-imgsourceetch1:1.3-15etch3mediumDSA-1743-1
libtk-imgsourcelenny1:1.3-release-7+lenny1mediumDSA-1743-1
tk8.3source(unstable)(not affected)
tk8.4source(unstable)8.4.16-1medium
tk8.4sourceetch(not affected)
tk8.4sourcesarge(not affected)

Notes

[etch] - tk8.4 <not-affected> (Vulnerability was introduced in 8.4.13)
[sarge] - tk8.4 <not-affected> (Vulnerability was introduced in 8.4.13)
- tk8.3 <not-affected> (Vulnerability was introduced in 8.4.13)

Search for package or bug name: Reporting problems