CVE-2007-5197

NameCVE-2007-5197
DescriptionBuffer overflow in the Mono.Math.BigInteger class in Mono 1.2.5.1 and earlier allows context-dependent attackers to execute arbitrary code via unspecified vectors related to Reduce in Montgomery-based Pow methods.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1397-1, DTSA-76-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mono (PTS)squeeze, squeeze (security)2.6.7-5.1fixed
squeeze (lts)2.6.7-5.1+deb6u1fixed
wheezy2.10.8.1-8fixed
wheezy (security)2.10.8.1-8+deb7u1fixed
jessie, sid3.2.8+dfsg-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
monosource(unstable)1.2.5.1-2high
monosourceetch1.2.2.1-1etch1highDSA-1397-1
monosourcelenny1.2.5.1-1+lenny1highDTSA-76-1

Search for package or bug name: Reporting problems