CVE-2007-5208

NameCVE-2007-5208
Descriptionhpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1462-1, DTSA-72-1
NVD severityhigh (attack range: remote)
Debian Bugs447341

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hplip (PTS)wheezy3.12.6-3.1+deb7u1fixed
wheezy (security)3.12.6-3.1+deb7u2fixed
jessie3.14.6-1+deb8u1fixed
stretch3.16.11+repack0-3fixed
buster, sid3.17.9+repack0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hplipsource(unstable)1.6.10-4.3medium447341
hplipsourceetch1.6.10-3etch1highDSA-1462-1
hplipsourcelenny1.6.10-4.2+lenny1highDTSA-72-1
hplipsourcesarge(not affected)

Notes

[sarge] - hplip <not-affected> (This code was using smtp directly)

Search for package or bug name: Reporting problems