CVE-2007-5300

NameCVE-2007-5300
DescriptionOff-by-one error in the do_login_loop function in libwzd-core/wzd_login.c in wzdftpd 0.8.0, 0.8.2, and possibly other versions allows remote attackers to cause a denial of service (daemon crash) via a long USER command that triggers a stack-based buffer overflow. NOTE: some of these details are obtained from third party information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1452-1
NVD severitymedium (attack range: remote)
Debian Bugs446192

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wzdftpd (PTS)wheezy0.8.3-6.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wzdftpdsource(unstable)0.8.2-2.1medium446192
wzdftpdsourceetch0.8.1-2etch1mediumDSA-1452-1
wzdftpdsourcesarge0.5.2-1.1sarge3mediumDSA-1452-1

Search for package or bug name: Reporting problems