CVE-2007-5372

NameCVE-2007-5372
DescriptionMultiple SQL injection vulnerabilities in (a) LedgerSMB 1.0.0 through 1.2.7 and (b) DWS Systems SQL-Ledger 2.x allow remote attackers to execute arbitrary SQL commands via (1) the invoice quantity field or (2) the sort field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs446366

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sql-ledger (PTS)wheezy3.0.3-1vulnerable
jessie3.0.6-2vulnerable
stretch, sid3.0.8-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sql-ledgersource(unstable)(unfixed)unimportant446366

Notes

It's documented behaviour that SQL-Ledger should only be run in an
authenticated HTTP zone and without untrusted users

Search for package or bug name: Reporting problems