CVE-2007-5707

NameCVE-2007-5707
DescriptionOpenLDAP before 2.3.39 allows remote attackers to cause a denial of service (slapd crash) via an LDAP request with a malformed objectClasses attribute. NOTE: this has been reported as a double free, but the reports are inconsistent.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1541-1
NVD severityhigh (attack range: remote)
Debian Bugs440632

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldap2source(unstable)(not affected)
openldap2.2source(unstable)(unfixed)high
openldap2.3source(unstable)2.3.38-1medium440632
openldap2.3sourceetch2.3.30-5+etch1highDSA-1541-1

Notes

- openldap2 <not-affected> (slapd not built)

Search for package or bug name: Reporting problems