CVE-2007-5712

NameCVE-2007-5712
DescriptionThe internationalization (i18n) framework in Django 0.91, 0.95, 0.95.1, and 0.96, and as used in other products such as PyLucid, when the USE_I18N option and the i18n component are enabled, allows remote attackers to cause a denial of service (memory consumption) via many HTTP requests with large Accept-Language headers.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1640-1
NVD severitylow (attack range: remote)
Debian Bugs448838
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)squeeze, squeeze (security)1.2.3-3+squeeze10fixed
squeeze (lts)1.2.3-3+squeeze14fixed
wheezy1.4.5-1+deb7u8fixed
wheezy (security)1.4.5-1+deb7u13fixed
jessie1.7.7-1fixed
jessie (security)1.7.7-1+deb8u2fixed
stretch, sid1.7.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)0.96-1.1low448838
python-djangosourceetch0.95.1-1etch2lowDSA-1640-1

Search for package or bug name: Reporting problems