CVE-2007-5898

NameCVE-2007-5898
DescriptionThe (1) htmlentities and (2) htmlspecialchars functions in PHP before 5.2.5 accept partial multibyte sequences, which has unknown impact and attack vectors, a different issue than CVE-2006-5465.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1444-1
NVD severitymedium (attack range: remote)
Debian Bugs453295
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.41-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.9+dfsg-0+deb8u1fixed
stretch, sid5.6.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.2.5-1medium453295
php5sourceetch5.2.0-8+etch9mediumDSA-1444-1

Notes

http://cvs.php.net/viewvc.cgi/php-src/ext/standard/html.c?r1=1.111.2.2.2.14&r2=1.111.2.2.2.15&view=patch
fixed in php5/etch svn

Search for package or bug name: Reporting problems