CVE-2007-5965

NameCVE-2007-5965
DescriptionQSslSocket in Trolltech Qt 4.3.0 through 4.3.2 does not properly verify SSL certificates, which might make it easier for remote attackers to trick a user into accepting an invalid server certificate for a spoofed service, or trick a service into accepting an invalid client certificate for a user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11fixed
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
buster, stretch4:4.8.7+dfsg-11fixed
sid4:4.8.7+dfsg-15fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt-x11-freesource(unstable)(not affected)
qt4-x11source(unstable)4.3.3-1medium
qt4-x11sourceetch(not affected)

Notes

[etch] - qt4-x11 <not-affected> (Vulnerable code was introduced in 4.3)
- qt-x11-free <not-affected> (Vulnerable code was introduced in 4.3)

Search for package or bug name: Reporting problems