CVE-2007-6170

NameCVE-2007-6170
DescriptionSQL injection vulnerability in the Call Detail Record Postgres logging engine (cdr_pgsql) in Asterisk 1.4.x before 1.4.15, 1.2.x before 1.2.25, B.x before B.2.3.4, and C.x before C.1.0-beta6 allows remote authenticated users to execute arbitrary SQL commands via (1) ANI and (2) DNIS arguments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1417-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)wheezy1:1.8.13.1~dfsg1-3+deb7u3fixed
wheezy (security)1:1.8.13.1~dfsg1-3+deb7u7fixed
jessie1:11.13.1~dfsg-2+deb8u2fixed
jessie (security)1:11.13.1~dfsg-2+deb8u4fixed
stretch1:13.14.1~dfsg-2+deb9u1fixed
stretch (security)1:13.14.1~dfsg-2+deb9u2fixed
buster, sid1:13.17.2~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:1.4.15~dfsg-1medium
asterisksourceetch1:1.2.13~dfsg-2etch2mediumDSA-1417-1
asterisksourcesarge1:1.0.7.dfsg.1-2sarge6mediumDSA-1417-1

Search for package or bug name: Reporting problems