CVE-2007-6282

NameCVE-2007-6282
DescriptionThe IPsec implementation in Linux kernel before 2.6.25 allows remote routers to cause a denial of service (crash) via a fragmented ESP packet in which the first fragment does not contain the entire ESP header and IV.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1630-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fai-kernelssourceetch1.17+etch.22etch2highDSA-1630-1
linux-2.6source(unstable)2.6.25-1high
linux-2.6sourceetch2.6.18.dfsg.1-22etch2highDSA-1630-1
linux-2.6.24source(unstable)2.6.24-6~etchnhalf.4high
user-mode-linuxsourceetch2.6.18-1um-2etch.22etch2highDSA-1630-1

Notes

Upstream commit 920fc941a9617f95ccb283037fe6f8a38d95bb69

Search for package or bug name: Reporting problems