CVE-2007-6335

NameCVE-2007-6335
DescriptionInteger overflow in libclamav in ClamAV before 0.92 allows remote attackers to execute arbitrary code via a crafted MEW packed PE file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1435-1, DTSA-101-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)squeeze0.98.1+dfsg-1+deb6u3fixed
squeeze (lts)0.98.1+dfsg-1+deb6u4fixed
wheezy0.98.5+dfsg-0+deb7u2fixed
jessie0.98.6+dfsg-1fixed
stretch, sid0.98.7+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.92~dfsg-1~volatile2high
clamavsourceetch0.90.1-3etch8highDSA-1435-1
clamavsourcelenny0.91.2-4.0lenny1highDTSA-101-1
clamavsourcesarge(not affected)

Notes

[sarge] - clamav <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems