CVE-2007-6427

NameCVE-2007-6427
DescriptionThe XInput extension in X.Org Xserver before 1.4.1 allows context-dependent attackers to execute arbitrary code via requests related to byte swapping and heap corruption within multiple functions, a different vulnerability than CVE-2007-4990.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1466-2, DTSA-110-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)buster2:1.20.4-1+deb10u4fixed
buster (security)2:1.20.4-1+deb10u9fixed
bullseye (security), bullseye2:1.20.11-1+deb11u6fixed
bookworm2:21.1.7-3fixed
sid, trixie2:21.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xfree86sourcesarge4.3.0.dfsg.1-14sarge7DSA-1466-2
xorg-serversourceetch2:1.1.1-21etch3DSA-1466-2
xorg-serversourcelenny2:1.3.0.0.dfsg-12lenny2DTSA-110-1
xorg-serversource(unstable)2:1.4.1~git20080105-2

Search for package or bug name: Reporting problems