CVE-2007-6429

NameCVE-2007-6429
DescriptionMultiple integer overflows in X.Org Xserver before 1.4.1 allow context-dependent attackers to execute arbitrary code via (1) a GetVisualInfo request containing a 32-bit value that is improperly used to calculate an amount of memory for allocation by the EVI extension, or (2) a request containing values related to pixmap size that are improperly used in management of shared memory by the MIT-SHM extension.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1466-2, DTSA-110-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)wheezy2:1.12.4-6+deb7u6fixed
wheezy (security)2:1.12.4-6+deb7u7fixed
jessie2:1.16.4-1+deb8u1fixed
jessie (security)2:1.16.4-1+deb8u2fixed
stretch2:1.19.2-1+deb9u1fixed
stretch (security)2:1.19.2-1+deb9u2fixed
buster, sid2:1.19.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xfree86sourcesarge4.3.0.dfsg.1-14sarge7highDSA-1466-2
xorg-serversource(unstable)2:1.4.1~git20080105-2high
xorg-serversourceetch2:1.1.1-21etch3highDSA-1466-2
xorg-serversourcelenny2:1.3.0.0.dfsg-12lenny2highDTSA-110-1

Search for package or bug name: Reporting problems