CVE-2007-6681

NameCVE-2007-6681
DescriptionStack-based buffer overflow in modules/demux/subtitle.c in VideoLAN VLC 0.8.6d allows remote attackers to execute arbitrary code via a long subtitle in a (1) MicroDvd, (2) SSA, and (3) Vplayer file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1543-1
NVD severityhigh (attack range: remote)
Debian Bugs458318
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)squeeze (security), squeeze1.1.3-1squeeze6fixed
wheezy2.0.3-5+deb7u1fixed
wheezy (security)2.0.3-5+deb7u2fixed
sid, jessie2.2.0~rc2-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)0.8.6.c-4.1low458318
vlcsourceetch0.8.6-svn20061012.debian-5.1+etch2highDSA-1543-1
vlcsourcelenny0.8.6.c-4.1~lenny1high

Notes

see http://www.securityfocus.com/archive/1/485488/30/0/threaded

Search for package or bug name: Reporting problems